按 Enter 到主內容區
:::

TWCERT-電子報

:::

Linux Sudo 指令遭發現遠端執行任意程式碼嚴重漏洞

發布日期:
字型大小:
  • 發布單位:TWCERT/CC
  • 更新日期:2021-01-29
  • 點閱次數:1170
Linux Sudo 指令遭發現遠端執行任意程式碼嚴重漏洞 TWCERT/CC

CVE編號

CVE-2021-3156

內文

資安廠商發現一個存在已久的 Unix 常用指令 Sudo 存有嚴重資安漏洞,可讓任何使用者將執行權限提升到 root 等級。

資安廠商 Qualys 日前發表研究報告,指出該公司旗下的資安研究團隊,發現一個存在已久的 Unix 系作業系統常用的指令 Sudo,存有嚴重資安漏洞,可讓任何使用者將執行權限提升到 root 等級。

Sudo 是個廣泛內建在各種泛 Unix 作業系統中的指令,可以暫時讓用戶以其他帳戶的密碼,執行更高權限的程式或指令。根據 Qualys 的報告,這個漏洞自從 2011 年七月以來,就存在於多個泛 Unix 系的作業系統之中,包括 Ubuntu、Debian、Fedora 等廣受歡迎的 Lunix distribution 發行版本中的 Sudo 指令,都存有此一漏洞。

這個漏洞的 CVE 編號為 CVE-2021-3156,Qulays 將之稱為「Baron Samedit」;目前 NVD 尚未針對這個漏洞提供 CVSS 危險程度評分。

Qualys 在其研究報告中,也針對各大 Unix 系作業系統,發展出基於此一漏洞的各種模擬攻擊方法;但 Qualys 也指出,這個漏洞必須由駭侵者在電腦前面操作;如沒有事先登入的話,駭侵者無法以遠端執行方式利用此漏洞提升執行權限。

也因為駭侵者必須先取得登入使用的權限,因此資安專家認為這會限制該漏洞的大規模使用可能性;但如果被攻擊的系統本身已先透過其他方式遭到入侵(例如植入僵屍網路惡意軟體),那麼攻擊者仍有可能利用此漏洞,將己身的執行權限提升至 root 等級。

目前 Sudo 指令的開發者,以及各大 Linux distribution 的發行者,皆已針對這個漏洞發布修補程式;用戶應將系統中的 Sudo 指令升級至版本 1.9.5p2,即可解決此一漏洞。

影響產品

各大 Unix 系作業系統中的 Sudo 指令,版本 1.8.2 至 1.8.31p2、以及1.9.0 至 1.9.5p1

解決辦法

升級 Sudo 指令至 1.9.5p2
回頁首