按 Enter 到主內容區
:::

TWCERT-電子報

:::

WordPress 外掛程式嚴重資安漏洞,可導致系統遭挾持

發布日期:
字型大小:
  • 發布單位:TWCERT/CC
  • 更新日期:2021-02-17
  • 點閱次數:567
WordPress 外掛程式嚴重資安漏洞,可導致系統遭挾持 TWCERT/CC

CVE編號

CVE-2020-35942、CVE-2020-35943

內文

WordPress 外掛程式 NextGen Gallery 遭發現兩個資安漏洞,使近 800,000 個 WordPress 網站存有遭駭侵者發動多種攻擊,甚至取得系統控制權限的風險。

WordPress 外掛程式 NextGen Gallery 遭發現兩個資安漏洞,可能使得近 800,000 個 WordPress 網站存有遭駭侵者發動多種攻擊,甚至取得系統控制權限的資安風險。

NetxGen Gallery 是可安裝在 WordPress 開源架站軟體上的擴充用外掛程式,可讓網站管理者大量上傳相片到其 WordPress 網站中,並且進行更有效率的管理。

資安廠商 Wordfence 旗下的研究人員,日前發現 NextGen Gallery 存有兩個資安漏洞;這兩個資安漏洞都可讓駭侵者發動「跨站請求偽造」(cross-site request forgery, CSRF)攻擊,駭侵者可利用這兩個漏洞取得網站控制權,進一步對其他網站發動各種攻擊,例如將訪客導向至惡意網站、注入垃圾訊息、進行釣魚攻擊等。

危險程度評級為嚴重等級,CVSS 分數高達 9.6 分的 CVE-2020-35942 漏洞,其問題發生於 NextGen Gallery 用來保護各種設定的程式碼錯誤;駭侵者可讓網站管理者點擊特定連結,對網站發出特製的連線要求,藉以誘發錯誤。

另一個危險程度為「高」等級,CVSS 分數為 8.8 分的 CVE-2020-35943 漏洞,問題則發生在 NextGen Gallery 在處理 AJAX 的驗證流程錯誤,駭侵者只要誘導網站管理者上傳一個藏有惡意程式碼的一般圖形檔,即可誘發這個錯誤,進而發動攻擊。

這兩個漏洞存於 NextGen Gallery 3.5.0 版本之前,開發者推出的 3.5.0 版,已經針對這兩個漏洞修復完成;有安裝 NextGen Gallery 的 WordPress 網站,其管理者應立即更新至最新版本,以降低遭到攻擊的風險。

影響產品

NextGen Gallery 3.5.0 先前版本

解決辦法

將 NextGen Gallery 升級至 3.5.0 或後續版本
回頁首